Bug #235

Omnirib dist build error

Added by Florian Lier over 6 years ago. Updated over 6 years ago.

Status:ClosedStart date:2014-05-09
Priority:HighDue date:
Assignee:Arne Nordmann% Done:

0%

Category:RecipeSpent time:0.20 hour
Target version:-

Description

If seems there is something wrong with either the build-flow or a command in the scc project.

Started by upstream project "scc-master-toolkit-omnirob-nightly" build number 1
originally caused by:
 Started by build flow distribution-buildflow.omnirob-nightly#1
Building in workspace /homes/flier/Projects/Ongoing/CITK/distinstaller/jenkins/jobs/scc-master-toolkit-omnirob-nightly/workspace/label/master
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository git://gitorious.org/qt-labs/scxml.git
 > git init /homes/flier/Projects/Ongoing/CITK/distinstaller/jenkins/jobs/scc-master-toolkit-omnirob-nightly/workspace/label/master
Fetching upstream changes from git://gitorious.org/qt-labs/scxml.git
 > git --version
 > git fetch --tags --progress git://gitorious.org/qt-labs/scxml.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url git://gitorious.org/qt-labs/scxml.git
 > git config remote.origin.fetch +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url git://gitorious.org/qt-labs/scxml.git
Fetching upstream changes from git://gitorious.org/qt-labs/scxml.git
 > git fetch --tags --progress git://gitorious.org/qt-labs/scxml.git +refs/heads/*:refs/remotes/origin/*
Checking out Revision 9be5070e56f170a239dcc075f9dc5b21a1ea8a4d (origin/master)
 > git config core.sparsecheckout
 > git checkout -f 9be5070e56f170a239dcc075f9dc5b21a1ea8a4d
 > git branch -a
 > git rev-parse remotes/origin/master^{commit}
 > git rev-parse remotes/origin/scc^{commit}
 > git rev-parse remotes/origin/statechartz^{commit}
 > git rev-parse remotes/origin/with-qml^{commit}
 > git checkout -b master 9be5070e56f170a239dcc075f9dc5b21a1ea8a4d
First time build. Skipping changelog.
[master] $ /bin/sh -xe /tmp/hudson4689812359035868748.sh
+ cd scc
+ qmake-qt4
+ make
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4 -I. -o main.o main.cpp
/usr/bin/rcc -name scc scc.qrc -o qrc_scc.cpp
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4 -I. -o qrc_scc.o qrc_scc.cpp
g++ -m64 -Wl,-O1 -o scc main.o qrc_scc.o    -L/usr/lib/x86_64-linux-gnu -lQtXmlPatterns -lQtCore -lpthread 
+ cp scc /tmp/omnirob/omnirob-nightly//bin
cp: cannot create regular file `/tmp/omnirob/omnirob-nightly//bin': No such file or directory
Build step 'Execute shell' marked build as failure
Finished: FAILURE

History

#2 Updated by Jan Moringen over 6 years ago

  • Description updated (diff)
  • Category set to Recipe

Is this job generated from Johannes' omnirob distribution? If so, it inherited a problem from the FAMULA distribution: the prefix directory is not created correctly in the distribution-prepare job.

Your commit addresses the symptom, not the root cause. The problem has to be fixed in the respective distribution descriptions.

#3 Updated by Johannes Wienke over 6 years ago

In any case, it should be solved with the recent commit. I think this can be closed.

#4 Updated by Florian Lier over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF